Ambient sounds won't work

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Ambient sounds won't work

Postby OkDoomer174 » Tue Aug 31, 2021 6:24 pm

I was trying to make an ambient sound using the AmbientSound thing in UDMF and SNDINFO, but I can't get it to work.

Here's the contents of my SNDINFO:
Code: Select allExpand view
sound ambient/hum "sounds/DSHUM.ogg"
$ambient 1 ambient/hum point continuous


And here's the arguments for my AmbientSound actor:
Code: Select allExpand view
arg0: 1 // Index
arg1: 100 // Volume
arg2: 0 // Minimum distance
arg3: 0 // Maximum distance
arg4: 0 // Scalar for arg3 and arg4


I've also attached my .PK3 (named .ZIP because forums) if you want to take a look at the map itself or the directory structure.
Any help would be much appreciated!
You do not have the required permissions to view the files attached to this post.
OkDoomer174
 
Joined: 21 Oct 2020
Location: The Shores of Hell
Discord: TheParadoxBox#5382
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: Intel (Modern GZDoom)

Re: Ambient sounds won't work

Postby OkDoomer174 » Wed Sep 01, 2021 7:06 am

Found out what the problem was. Here's my revised SNDINFO, for those wondering:
Code: Select allExpand view
ambient/hum DSHUM
$ambient 1 ambient/hum point continuous 1
OkDoomer174
 
Joined: 21 Oct 2020
Location: The Shores of Hell
Discord: TheParadoxBox#5382
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: Intel (Modern GZDoom)


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 0 guests