My Animated 3D Weapon Model is Messed Up

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

My Animated 3D Weapon Model is Messed Up

Postby SPZ1 » Mon Apr 05, 2021 11:12 am

It appears that the draw order is wrong. The cylinder is supposed to be in the center!! How do I fix this??


You do not have the required permissions to view the files attached to this post.
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: My Animated 3D Weapon Model is Messed Up

Postby Cherno » Mon Apr 05, 2021 1:40 pm

It looks like your model's normals face the wrong way. Invert/flip them.
User avatar
Cherno
 
Joined: 06 Dec 2016

Re: My Animated 3D Weapon Model is Messed Up

Postby SPZ1 » Mon Apr 05, 2021 2:26 pm

I tried flipping them a few times but it didn't do anything!
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: My Animated 3D Weapon Model is Messed Up

Postby SPZ1 » Sun Apr 18, 2021 10:35 am

Sorry for the double post but I have the same problem again. This time it is an .OBJ of what is supposed to be a flower. Also I found that the ROTATING keyword doesn't work on weapon models.


Screenshot_Doom_20210418_112432.jpg
You do not have the required permissions to view the files attached to this post.
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: My Animated 3D Weapon Model is Messed Up

Postby SPZ1 » Wed May 05, 2021 5:37 pm

One more post about how weapon models are messed up. The weird thing is that they are not transparent when spawned into the map as normal actors.


Ocarina.png
You do not have the required permissions to view the files attached to this post.
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: My Animated 3D Weapon Model is Messed Up

Postby ramon.dexter » Thu May 06, 2021 3:18 am

Yep, I've got exactly the same problem. Model spawned in map is ok, when used as a hud model, it is messed up.
User avatar
ramon.dexter
rudebwoy
 
Joined: 20 Oct 2015
Location: Kozolupy, Bohemia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: My Animated 3D Weapon Model is Messed Up

Postby ramon.dexter » Sat May 22, 2021 2:36 am

Hello, little update. I think I've found a halfway solution for this problem...

I noticed that my last weapon, that I created the same way as the others (the others work well without the bug of this thred) has the bug mentioned here. So, I grabbed it by the balls and spent some time playing with it.
- I don't think this is a bug of the model. After all, the model works 100% correct when placed on ground. The bug only appears when the model is used as a HUD weapon.
- so I started playing with model offsets. Because, the model placed on the ground is much farther from camera than the HUD weapon, maybe the bug is related to actual distance between the viewport (camera, etc.) and the model itself. So I checked my working model's offsets and found out that most of the models have Z offset like -10, while the new weapon has Z offset -3. So, I changed it to -4 ... and the problem is GONE!

So, if you want to solve this, try playing with models offsets in MODELDEF. I think this 'bug' is related to the renderer or camera. Not sure if I should report it.
User avatar
ramon.dexter
rudebwoy
 
Joined: 20 Oct 2015
Location: Kozolupy, Bohemia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: My Animated 3D Weapon Model is Messed Up

Postby SPZ1 » Thu Feb 03, 2022 11:42 am

This is quite a bump...

I figured it out by simply playing with the offset in MODELDEF...

ocarirna fix.png
You do not have the required permissions to view the files attached to this post.
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: My Animated 3D Weapon Model is Messed Up

Postby ramon.dexter » Fri Feb 04, 2022 6:32 am

Sometimes I have a feeling that I'm ignored...
User avatar
ramon.dexter
rudebwoy
 
Joined: 20 Oct 2015
Location: Kozolupy, Bohemia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 0 guests