Help with OBJ models and .MTL files

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Help with OBJ models and .MTL files

Postby SPZ1 » Fri Mar 12, 2021 11:58 am

I'm having some trouble with models. My OBJ models always cause GZDoom to spit out some script error warning that I can't figure out. My .MTL file is in place but it doesn't do anything!! I got the moon to work but I'm not having the same luck with the clock tower clock thing. This is demonstrated with the following link (I can't post it on this forum because the file size is too large! >:(


https://1drv.ms/u/s!Ap4KZFMds2L1hGbQrsYfwMSc8Ne4?e=ZhN2vH
User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois

Re: Help with OBJ models and .MTL files

Postby Cherno » Fri Mar 12, 2021 2:05 pm

Forget the mtl file. Instead, open the obj file in a text editor (can be done is SLADE) and search for all lines starting with "usemtl". Change the material paths following these so only the texture name remains. So, a line that refers to the texture "s1floorc" in your textures dir of your archive should just read "usemtl s1florc".
User avatar
Cherno
 
Joined: 06 Dec 2016

Re: Help with OBJ models and .MTL files

Postby SPZ1 » Fri Mar 12, 2021 4:41 pm

Excellent! Both models are now working!

User avatar
SPZ1
 
Joined: 02 Aug 2017
Location: Illinois


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 0 guests