Problems while making a skin

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!
Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Problems while making a skin

Postby Tartlman » Sat Oct 27, 2018 9:55 am

Not sure if this is the right place, but here goes.

I'm making a skin right now and i'm encountering a problem with the mugshot.
I have created an image for every frame, and made sure that S_SKIN defines the mugshot name.
However, it doesn't show for some odd reason. I'm certain that I edited the right file and that I am using the right skin.

Additionally, the name of the skin in player setup says skin1 and i don't know what I did wrong.

Finally, a gibbing death results on the sprite disappearing on the last frame, but i'm guessing that I left a frame out or something.

Edit: i've also noticed that the pain anim is missing but that's likely due to naming issues.

Here's the skin:
Attachments
lizardskin.wad
(139.69 KiB) Downloaded 6 times
User avatar
Tartlman
 
Joined: 11 Oct 2018
Discord: Tartlman#2947

Re: Problems while making a skin

Postby Enjay » Sat Oct 27, 2018 10:30 am

Your S_SKIN uses { at the start and } at the end. S_SKIN lumps don't do that (IIRC, they were originally designed for Doom Legacy and ZDoom just adopted them as they were, so that explains their non-standardness).


[edit]Something else to be aware of, your skin sprites are PNGs that are not in the Doom palette. If any player using any kind of translation other than the basic green uses this skin it might look bad. GZDoom needs to force it into the Doom palette first before applying the translation. Unfortunately, these sprites don't convert very well. Just a "heads up" ;) . [/edit]
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Problems while making a skin

Postby Tartlman » Sat Oct 27, 2018 10:35 am

That seemed to fix a lot of the problem. The only issue I have left is that the mug displays in the top left.
Any way to fix this apart from scaling all of them up manually?

Updated skin:
Attachments
lizardskin.wad
(145.19 KiB) Downloaded 7 times
User avatar
Tartlman
 
Joined: 11 Oct 2018
Discord: Tartlman#2947

Re: Problems while making a skin

Postby Enjay » Sat Oct 27, 2018 10:45 am

I think you'll either have to scale them up or paste them into an otherwise transparent graphic of the right size. I tried changing the offsets of the GOD image but that was ignored and it still showed in the same place. No, forget that. Changing offsets works. I just didn't save properly when doing it.



Image
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
 
 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Problems while making a skin

Postby Tartlman » Sat Oct 27, 2018 11:00 am

Alright, thanks! that seems to work fine.
User avatar
Tartlman
 
Joined: 11 Oct 2018
Discord: Tartlman#2947

Re: Problems while making a skin

Postby Tartlman » Sat Oct 27, 2018 11:00 am

oops, accidentally posted twice b/c of shitty internet
Last edited by Tartlman on Sat Oct 27, 2018 11:00 am, edited 1 time in total.
User avatar
Tartlman
 
Joined: 11 Oct 2018
Discord: Tartlman#2947


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 1 guest