Hires Images Lag for a while and then stop

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!
Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Hires Images Lag for a while and then stop

Postby TheGameratorT » Tue May 29, 2018 3:35 pm

So, I'm using full screen images in PNG format at a resolution of 2160x1080 and downscaling them using HIRES to fit 512x256.
I'm using them in a weapon like this:

FOXY ABCDEFGHIJKLMNOPQRSTUVWXYZ 1 BRIGHT
FOXI ABC 1 BRIGHT
Loop

But when I use the weapon the frames seem to not be loaded and struggle to appear smoothly. Only after getting them to loop 6 times they start to work normally as they should, is there a fix for that?

If I pause the game for 1 minute and continue it starts struggling again.

Also I tried precaching GL textures and didn't solved the problem.
User avatar
TheGameratorT
 
Joined: 04 Mar 2018
Location: Portugal
Discord: TheGameratorT#1850

Re: Hires Images Lag for a while and then stop

Postby Kinsie » Sat Jun 02, 2018 12:39 pm

TheGameratorT wrote:is there a fix for that?
Yes. Don't use 2160x1080 weapon sprites. You're hurling a whole lot of data into your GPU that the engine is probably struggling to do fast enough.
User avatar
Kinsie
A Concept Utterly Obsolete
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie


Return to Assets

Who is online

Users browsing this forum: No registered users and 1 guest