Font is showed in dark colors

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!
Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Font is showed in dark colors

Postby FFFFRRRR » Sat May 12, 2018 8:49 am

I have a problem with a custom font I made. The font-graphics are truecolor pngs, here are 3 examples:
Image Image Image
(I have attached the rest of the graphics in the zip).

Ingame, when used with HUDMESSAGE and the colors CR_White and CR_Cyan, they look like this:
Image
White is a bit lighter, so colors do seem to make a difference.

My FONTDEFS:
Spoiler:

I have used TEXTURES to scale them down a bit. There, these graphcis have the FRNUMx names.

Does anybody know what that could be?
Attachments
FRFONT.zip
(2.33 KiB) Downloaded 20 times
User avatar
FFFFRRRR
Toa D.
 
Joined: 04 Nov 2017

Re: Font is showed in dark colors

Postby Blue Shadow » Mon May 14, 2018 7:47 am

I think the issue is that the graphics consist of a single color. Each color provided by GZDoom is defined as a range, from darkest to lightest. From what I observed* during testing is that when the engine applies the color translation, it appears to start from the darkest shade of the chosen color to the lightest, and since your font graphics consist of only a single color, they get the darkest shade applied to them, and thus appear dark in the game.

You can solve this by creating your own font colors to go with your font.

Spoiler: *
User avatar
Blue Shadow
 
 
 
Joined: 14 Nov 2010

Re: Font is showed in dark colors

Postby Graf Zahl » Thu May 17, 2018 3:19 am

If you use FONTDEFS to define the font, add 'DONTTRANSLATE'. That will cause the font renderer to use the color normally used for console texts to colorize it instead of building a custom translation.
User avatar
Graf Zahl
Lead GZDoom Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Font is showed in dark colors

Postby FFFFRRRR » Sat May 19, 2018 9:25 am

Thanks for the help! DONTTRANSLATE worked.
User avatar
FFFFRRRR
Toa D.
 
Joined: 04 Nov 2017


Return to Assets

Who is online

Users browsing this forum: No registered users and 2 guests