Trouble with custom fonts (SOLVED)

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Trouble with custom fonts (SOLVED)

Postby Exosphere » Mon Nov 06, 2017 8:21 am

As the title states, I've been have some trouble with implementing custom fonts. I've been testing the number font from the ICARUS wad in my mod, and even with using the ZDoom wiki in how to create the necessary lump, the new font still wont appear for some reason. I've tried having the font as .lmp and .png, yet neither work.

Here is the code form the FONTDEF file.

Code: Select allExpand view
STATUSFONT
{
0 STTNUM0
1 STTNUM1
2 STTNUM2
3 STTNUM3
4 STTNUM4
5 STTNUM5
6 STTNUM6
7 STTNUM7
8 STTNUM8
9 STTNUM9
% STTPRCNT
- STTMINUS
   
NOTRANSLATION 109
}


Any thoughts?
Last edited by Exosphere on Sun Nov 26, 2017 8:49 pm, edited 1 time in total.
User avatar
Exosphere
 
Joined: 11 Jun 2017
Location: New England, US

Re: Trouble with custom fonts

Postby Graf Zahl » Mon Nov 06, 2017 8:55 am

No data, so no thoughts. I'm not a mind reader and cannot look into your unposted mod.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Trouble with custom fonts

Postby Exosphere » Mon Nov 06, 2017 9:55 am

Graf Zahl wrote:No data, so no thoughts. I'm not a mind reader and cannot look into your unposted mod.


I don't mean to sound rude, but what else do I need to include? There doesnt seem like anything else that would be necessary in my mind, however I should mention that all the font files (the .lmp files) are located in a folder, and the FONTDEF is outside the folder. Here is the basic file structure of my mod:

Code: Select allExpand view
Models (FOLDER)
Sprites (FOLDER) -----> The font files are in here
Decorate (FOLDER)
ACS (FOLDER)
Sounds (FOLDER)
README.txt
MODELDEF
DECORATE
GAMEINFO
GLDEFS
SNDINFO
KEYCONF
LOADACS
FONTDEFS
DEHACKED.lmp
TEXTURES



Although, I can send you a PM with my mod. I know this will sound stupid, but I am slightly hesitent to post my mod openly on the forums, even in its incomplete state.
User avatar
Exosphere
 
Joined: 11 Jun 2017
Location: New England, US

Re: Trouble with custom fonts

Postby Nero » Mon Nov 06, 2017 12:34 pm

Try moving the font files to a "graphics" folder.
User avatar
Nero
Royal Boredom....Why can't I do this in Windows?
 
Joined: 06 Sep 2006
Location: Middle of Nowheresville Il.

Re: Trouble with custom fonts

Postby Exosphere » Mon Nov 06, 2017 2:56 pm

Nero wrote:Try moving the font files to a "graphics" folder.


That did the trick! Thank ya! Just so I know for the future, should I put all pngs/lmps for fonts, and other HUD/UI stuff, in the "Graphics" folder from now on?
User avatar
Exosphere
 
Joined: 11 Jun 2017
Location: New England, US

Re: Trouble with custom fonts

Postby Kappes Buur » Mon Nov 06, 2017 6:13 pm

Graf Zahl's comment stands, simply because you did not furnish enough information in your inital post.
How were we supposed to know which format you used for your map, which then became clear with your next post.

But yes, for the zip or pk3 format,
custom font images, doom format, png, etc. go into GRAPHICS.
Then the fonts you want to use are specified in FONTDEFS.

Likewise with sounds,
custom sounds, mp3, flac, ogg, etc, go into SOUNDS.
Then the sounds you want to use are specified in SNDINFO.
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia, Canada


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 0 guests