Unusual Model Face Clipping (SOLVED)

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!

Moderators: GZDoom Developers, Raze Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Unusual Model Face Clipping (SOLVED)

Postby Exosphere » Tue Oct 24, 2017 9:15 am

In my ongoing attempt to use first person models, I have been able to finally use them correctly (thanks to R4L). Unfortunately I have encountered a rather big error. Some faces on the model are not being culled properly and are clearly visible. The model itself is intact and not missing any polygons/faces. I really have no idea what is wrong, and would like to get input from the wider ZDoom community. The image included shows the error and the faces that are visible are circled in red.
You do not have the required permissions to view the files attached to this post.
Last edited by Exosphere on Sun Nov 26, 2017 8:48 pm, edited 1 time in total.
User avatar
Exosphere
 
Joined: 11 Jun 2017
Location: New England, US

Re: Unusual Model Face Clipping

Postby Nash » Tue Oct 24, 2017 9:54 am

Model's scale may be too small/too large during export-time. Try messing around with its scale in your model editor then re-export and see what happens.
User avatar
Nash
Twitter/Facebook/Youtube: nashmuhandes
 
 
 
Joined: 27 Oct 2003
Location: Kuala Lumpur, Malaysia
Twitch ID: nashmuhandes
Github ID: nashmuhandes

Re: Unusual Model Face Clipping

Postby Dark-Assassin » Tue Oct 24, 2017 10:27 am

It's most likely too small. Scale it up by a factor of 10 from absolute 0 of the project's x/y/z coordinates and see how that goes.
User avatar
Dark-Assassin
 
Joined: 19 Mar 2009
Location: South Australia


Return to Assets (and other stuff)

Who is online

Users browsing this forum: No registered users and 0 guests