Odd Custom Font Issue

Ask about editing graphics, sounds, models, music, etc here!
Shaders (GLSL) and SNDINFO questions also go here!
Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Odd Custom Font Issue

Postby Boondorl » Thu Jul 12, 2018 12:13 am

To start, this isn't actually my mod but someone else's that I've been fixing up (Brutal Doom 64). For the longest time, there's been an issue with the font where it writes from the top down (that's probably not actually what's happening, but is a good quick explanation). I've been looking to fix it for a while and this problem is driving me insane because I have absolutely no idea how to do it.

Here's what I mean:



Notice the periods. This happens with all characters including -, _, and ,. How it's set up is that in the map wad itself are a series of textures set to replace Doom's default fonts FONTA*** and FONTB***. These textures are in both the patch table and TEXTUREx table (if there's a better way to do this, I'm all ears since I didn't set this up and would gladly do it a better way). There's no FONTDEFS file defined either. What's strange is that both the large font and console font don't seem to have this issue meaning it's just the small font that's giving problems.
Boondorl
 
Joined: 11 Jul 2018

Re: Odd Custom Font Issue

Postby wildweasel » Thu Jul 12, 2018 12:52 am

Find the image lump for the comma character, and align it down a few pixels. The problem you're seeing here is that the comma is several pixels shorter than the characters next to it, and Doom renders fonts from the top row down.
User avatar
wildweasel
「お前はもうトースト」[you are already toast.]
Moderator Team Lead
 
Joined: 15 Jul 2003

Re: Odd Custom Font Issue

Postby Boondorl » Thu Jul 12, 2018 6:48 pm

I've tried manually editing the problem images and reconverting them to a Doom lump to include space at the top and editing via TEXTUREx but Doom just seems to ignore it and trims empty space. I also just checked without the mod's main assets pk3 to see if it was overriding anything and still have the problem. The weird part is that none of the other fonts, including the original Doom's small font, require empty space to work properly (at least not to my knowledge, I haven't dug very deep into modding fonts in ZDoom).

I'll keep trying a bunch of different things until it decides to work. I don't think it even needs to be in the patch table since it's not being used as a wall texture at any point.

EDIT: Ok, figured it out. Turns out it was the STCFN*** fonts that needed to be changed since that's what ZDoom uses for the small menu and chat text. Adding some padding on the top where needed worked like a charm. They also needed to be removed from the patch and TEXTUREx tables (don't ask why they were there, I don't know either).
Boondorl
 
Joined: 11 Jul 2018

Re: Odd Custom Font Issue

Postby Kinsie » Tue Aug 07, 2018 6:33 am

Boondorl wrote:They also needed to be removed from the patch and TEXTUREx tables (don't ask why they were there, I don't know either).
This is an artifact of the terrible, horrible, no good, very bad Skulltag port of the ancient Doomsday TC that BD64 is based off of. I have no clue why they created TEXTUREx entries for every sprite and graphic in the TC and IWAD, and frankly I don't wanna know.
User avatar
Kinsie
A Concept Utterly Obsolete
 
Joined: 22 Oct 2004
Location: MAP33
Discord: Find Me...
Twitch ID: thekinsie


Return to Assets

Who is online

Users browsing this forum: No registered users and 1 guest