One-sided linedefs clipping fake "3d" architecture

Ask about mapping, UDMF, using DoomBuilder/editor of choice, etc, here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.
Antnee
Posts: 4
Joined: Tue Nov 06, 2018 10:54 am
Discord: 1522

One-sided linedefs clipping fake "3d" architecture

Post by Antnee »

Here's the setup:



Outside area, ceiling height of 512. The bottom "pillar" has a floor height of 512. The top "pillar" is an empty space, surrounded by a sector with a lower ceiling- 256 high. Setting the "do not draw skywalls" flag on that surrounding sector works to not block the sector behind it, but the 1 sided linedefs still occlude.



I'm used to mapping for Doom64ex, where this was a simple linedef flag on the one-sided linedefs (No Occlusion). But I can't find how to overcome this in GZdoom.

Is there some trick I'm missing?

Edit: And interestingly I see that the "noskywalls" flag is listed in the github flag list, but it doesn't actually do anything when applied to my 1 sided lines. (line 143 in github)

https://github.com/coelckers/gzdoom/blo ... #L215-L223

Return to “Mapping”