Custom Things not showing up in UDB

Ask about mapping, UDMF, using DoomBuilder/editor of choice, etc, here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Custom Things not showing up in UDB

Postby fiend-o-hell » Sat May 29, 2021 3:35 pm

Hello,

I've spent hours on this. Why can't I see any of the my zscript actors on the UDB (R3274 at the time of this writing) things list.

From reading around the internet, here are two key requirements...
1)Include editor comments in the default block of the class definition.
2)Assign the class a doomednum in MAPINFO.

editor_user_things.wad
is a test wad that I have prepared. Does everything look correct?
This is what I see in my editor...
This is what I see on my editor.
You do not have the required permissions to view the files attached to this post.
fiend-o-hell
 
Joined: 10 May 2019
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)

Re: Custom Things not showing up in UDB

Postby boris » Sun May 30, 2021 12:50 am

You also need to include gzdoom.pk3 as a resource (but exclude it from testing).

Also your version of UDB is super old. Update.
boris
I post less than Manc and Hobo
 
Joined: 15 Jul 2003

Re: Custom Things not showing up in UDB

Postby fiend-o-hell » Sun May 30, 2021 8:50 am

That did the trick. Thanks!
fiend-o-hell
 
Joined: 10 May 2019
Operating System: Windows 10/8.1/8/201x 64-bit
Graphics Processor: nVidia (Modern GZDoom)


Return to Mapping

Who is online

Users browsing this forum: No registered users and 0 guests