Page 1 of 2

Setting ambient sound distance?!

PostPosted: Wed Dec 23, 2020 9:09 pm
by Mav3r1ck
I've just recently started using ambient sounds to improve the atmosphere of maps but I'm having issues.

How do I properly set the sound distances? I tried for example setting 32 to both min and max distances, but I can hear them all over the map and it doesn't make sense.

I was under the impression that the ambient sound radius circles in 2d mode on the map have different sizes depending on the min and max values being set but it's so large it almost fills the whole map.

Am I missing something here?

Re: Setting ambient sound distance?!

PostPosted: Wed Dec 23, 2020 11:15 pm
by Enjay
Does this help at all? It is a sound set to have a very small (probably too small) radius:

For some reason, I have only been able to get it to work if I place a general ambient thing (ednum 14065). If I define an ambient sound and place it using its own number (in this case it would be 14001 because it is ambient sound number 1) the distance and fade parameters don't seem to do anything.

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 6:15 am
by Mav3r1ck
I can only get certain min and max if I set the &rolloff in the sndinfo for the ambient sounds. And yes, I also set the parameters and it isn't doing anything.

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 7:11 am
by Enjay
Hmmm... OK, not sure what's going wrong for you.

Perhaps the attached will help. It's a simple ambient sound placed in an equally simple map - but I have set the thing parameters so that it can only be heard when you are in (or very near) the 128x128 square in the middle.

[edit]Ack, the board attachment quota has been reached - give me a moment[/edit]

[edit2]Here www.aspectsweb.co.uk/enjay/doom/examples/Ambient.pk3 [/edit]

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 7:14 am
by Mav3r1ck
Is gzdoom 4.4.2.0 the latest version? I also use UDB.

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 7:15 am
by Enjay
GZDoom 4.5.0 is latest, but this should have been working for many versions back. I am aslo using UDB. (Example is now uploaded.)

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 7:19 am
by Mav3r1ck
Thx, I'll give a go after work.

EDIT: Will you be able to post an example code of the ambient sounds in the sndinfo you have?

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 8:11 am
by Enjay
The file that I posted above has a very simple SNDINFO entry:

Code: Select allExpand view
HUM01   DSHUM01

$ambient 1 HUM01 POINT CONTINUOUS 1.0


The rest is handled by the parameters on the sound thing in the map.

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 8:42 am
by Mav3r1ck
Mine is set up this way

Code: Select allExpand view
compy1 compy1

&ambient 1 compy1 point continuous 1.0


I'm using sounds from realm667 for computers, machinery and he'll.

Our setup matches but it doesn't explain why the parameters on the ambient sound thing in the map don't work for me though.

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 1:19 pm
by Enjay
Well, your SNDINFO is basically the same as mine so the problem must lie elsewhere.

I mentioned it above, but make sure that you are using a thing with ednum 14065 (or the non-gravity version 14067) and set the first parameter as 1 to play ambient sound #1 rather than using the auto-assigned ednum 14001

Have you set the parameters exactly I did in the example? (I know they are probably not the values that you need, but it may work as a starting point.)

If you can't get it working, can you upload your project somewhere for me (or someone else) to check?

Re: Setting ambient sound distance?!

PostPosted: Thu Dec 24, 2020 1:24 pm
by Mav3r1ck
It will be a few hours before I can. I will attempt what you have suggested.

EDIT: I tried to replicate the example.wad you attached with the sound and sndinfo in the wad itself but no matter what I do to the min (fading sound) and max (heard sound) parameters, they're ignored. In 2d mode, all it does is show a radius circle that covers the entire map regardless to whatever I change it to. So I don't understand what I could possibly be doing wrong.

Re: Setting ambient sound distance?!

PostPosted: Tue Dec 29, 2020 9:28 am
by Mav3r1ck
Sorry to bump this topic.

I got the latest version of GZDoom but I am still having the same issue with the ambient things. I am making maps in UDMF if this helps.

And also, why doesn't my menu scale anymore?

Re: Setting ambient sound distance?!

PostPosted: Tue Dec 29, 2020 12:20 pm
by Enjay
If it's still not working, can you post an example with how you have things set up? Basically something similar to the example that I posted but with your code and a map saved how you are doing it should suffice.

For the menu, have you tried changing the m_cleanscale value at the console (it's also in the misc menu options I think).

Re: Setting ambient sound distance?!

PostPosted: Tue Dec 29, 2020 4:04 pm
by Mav3r1ck
I think I messed up when I was attaching the file just now so it's not letting me upload an example you requested.

My maps are all in UDMF and use environmental reverbs. Would this clash with ambient reverbs?

Is there anything that can clash with ambient sound reverbs?

Re: Setting ambient sound distance?!

PostPosted: Tue Dec 29, 2020 8:31 pm
by Enjay
Reverbs shouldn't affect this (they don't for me).

Can you upload the file elsewhere - a file sharing site of some sort? (If it's big-ish, it won't attach to the forum - and it doesn't have to be that big at all - though I forget what the limit is.)

If not, could you just post a screenshot of the Action/Tag/Misc tab of the thing editor for one of your sound objects?

I'm really stumped with this because I was doing some editing tonight and I placed quite a few sound items - all with individually tailored distances - no problem at all. So it must be something at your end, but I can't think what it would be.

When you open my example in UDB, does it show the reduced distance circles correctly for you?