[4.4.2] Sloped Ceiling not sloped in game

Ask about mapping, UDMF, using DoomBuilder/editor of choice, etc, here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

[4.4.2] Sloped Ceiling not sloped in game

Postby ASO3000 » Wed Oct 28, 2020 11:29 am

I am building a map (UDMF in UDB).
I have several sloped ceilings. Almost all of which are shown the way they should be in visual mode and ingame.
However, one of them is NOT shown as sloped. It's definitely applied, since if I remove the line special, I get HOM from empty textures - but it just won't show up as sloped.
It is an exact mirror of the slope on the other side of the room and I double-triple-n-checked that nothing is different. Really the ONLY difference between those lines and sectors are their unique numbers.
I have no idea what is going on.
I am using GZD 4.4.2 with OpenGl renderer. I also tried out all the other renderers (hardware and software) and ALL show the very same non-existing slope.
Is there something like a limit on slopes in a level or something? I have no. I can post the wad if needed.
User avatar
ASO3000
 
Joined: 14 Jun 2019

Re: [4.4.2] Sloped Ceiling not sloped in game

Postby Kappes Buur » Wed Oct 28, 2020 12:30 pm

ASO3000 wrote:..... and I double-triple-n-checked that nothing is different. Really the ONLY difference .....


It is all well and good to give a wordy account of what you did, but the matter of fact is that one would have to be able to inspect your pwad in order to help you.

ASO3000 wrote: I can post the wad if needed.


That should always be the first thing to do, in order to eliminate assumptions and conjectures.
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia, Canada

Re: [4.4.2] Sloped Ceiling not sloped in game

Postby ASO3000 » Wed Oct 28, 2020 2:35 pm

Alright, sorry, but right now when I loaded the wad with GZD just to test it without UDB, the slopes were there.
And when I then tested it again in UDB, the slopes were there! I HAVEN'T CHANGED ANYTHING!
So sorry for the commotion, maybe it was just a gremlin. I will continue monitoring the issue, though.
User avatar
ASO3000
 
Joined: 14 Jun 2019


Return to Mapping

Who is online

Users browsing this forum: No registered users and 2 guests