Disappearing Ambient Sounds After Traveling

Ask about mapping, UDMF, using DoomBuilder/editor of choice, etc, here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Disappearing Ambient Sounds After Traveling

Postby RastaManGames » Thu Apr 23, 2020 8:40 am

I have few maps, that was connected via "hub" (big level with many roads to go).
And after visiting one map and returning to another, i noticed, that ambient sounds are fall silent.
This is bad and not intended to be like that. Maybe i did something wrong?

P.S.: Uh... Really sad, that there is about month without any answer... :cry:
User avatar
RastaManGames
Syberian Doom Fan
 
Joined: 13 Mar 2014
Location: Russian Federation, Krasnoyarsk
Discord: ℝ𝕒𝕀π•₯π•’π•„π•’π•Ÿπ”Ύπ•’π•žπ•–π•€#4168
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: Disappearing Ambient Sounds After Traveling

Postby Misery » Sun Nov 29, 2020 1:01 pm

Edit: Nevermind, I misunderstood the question.
Last edited by Misery on Sun Nov 29, 2020 7:22 pm, edited 1 time in total.
User avatar
Misery
 
Joined: 04 Nov 2018

Re: Disappearing Ambient Sounds After Traveling

Postby Enjay » Sun Nov 29, 2020 3:00 pm

If I'm reading the original post correctly, I think it means that ambient sounds that were audible on a map when the map was left to go to another in the hub can no longer be heard when you return to the map even though nothing has been deliberately done (like a script or whatever) to make them silent/deactivated.

Is that correct?

If so, it seems like it might be a bug. Is it possible to reproduce it in a small cut-down example WAD/PK3? If so, posting it with a bug report would be the way to go.
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
Β 
Β 
 
Joined: 15 Jul 2003
Location: Scotland

Re: Disappearing Ambient Sounds After Traveling

Postby drfrag » Sun Nov 29, 2020 3:41 pm

A similar bug or precisely that one was fixed recently, it's an old post.
User avatar
drfrag
Os voy a romper a pedazos!
Vintage GZDoom Developer
 
Joined: 23 Apr 2004
Location: Spain
Discord: drfrag#3555
Github ID: drfrag666

Re: Disappearing Ambient Sounds After Traveling

Postby Enjay » Sun Nov 29, 2020 5:10 pm

I thought I'd seen a bug report, but couldn't find it. So I just thought that it must be this thread that I was remembering.

Did a bit more digging - I assume that it was this one? viewtopic.php?f=7&t=69100
User avatar
Enjay
Everyone is a moon, and has a dark side which he never shows to anybody. Twain
Β 
Β 
 
Joined: 15 Jul 2003
Location: Scotland


Return to Mapping

Who is online

Users browsing this forum: No registered users and 2 guests