-SHOOTABLE x Thing_SetGoal

Ask about ACS, DECORATE, ZScript, or any other scripting questions here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Please bear in mind that the people helping you do not automatically know how much you know. You may be asked to upload your project file to look at. Don't be afraid to ask questions about what things mean, but also please be patient with the people trying to help you. (And helpers, please be patient with the person you're trying to help!)

-SHOOTABLE x Thing_SetGoal

Postby Logan MTM » Thu Oct 28, 2021 7:55 am

Hi everyone.

Any Actor with -SHOOTABLE flag DO NOT move by Thing_SetGoal.

Question: Why?

Thank you all!
User avatar
Logan MTM
I can see you...
 
Joined: 16 Jan 2006
Location: Rio de Janeiro - Brazil

Re: -SHOOTABLE x Thing_SetGoal

Postby Player701 » Tue Nov 23, 2021 7:35 am

There is a check in the engine code for this flag in Thing_SetGoal, but I have no idea why it's there. This function is supposed to work with monsters, so this may or may not be a bug - perhaps it should check for ISMONSTER instead.
User avatar
Player701
 
 
 
Joined: 13 May 2009
Location: Russia
Discord: Player701#8214
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support

Re: -SHOOTABLE x Thing_SetGoal

Postby Logan MTM » Tue Nov 23, 2021 7:22 pm

Strange ( :? ) but there must be some reason for that. I solved it by other methods.
I appreciate and thank you for the explanation! :mrgreen:
User avatar
Logan MTM
I can see you...
 
Joined: 16 Jan 2006
Location: Rio de Janeiro - Brazil

Re: -SHOOTABLE x Thing_SetGoal

Postby Player701 » Wed Nov 24, 2021 2:11 am

Considering that there can be (and in fact are) things that are shootable but are not monsters, and that the reverse is also true, it could be a bug but it could also break compatibility if it gets fixed. Considering that a far less gameplay-affecting issue (related to sounds) was not addressed for compability concerns, I think this one doesn't stand much chance of being addressed either.

BTW, I was subscribed to this thread but I did not receive any email notification. I've been running my own mail server for some time now, so I can see in its logs that there were no attempts by the ZDoom forum to deliver the mail (only got a notification about a new post here but nothing else). This is definitely not a problem on my end...
User avatar
Player701
 
 
 
Joined: 13 May 2009
Location: Russia
Discord: Player701#8214
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Scripting

Who is online

Users browsing this forum: yum13241 and 1 guest