Problems with "Thingcountsector"

Ask about ACS, DECORATE, ZScript, or any other scripting questions here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Problems with "Thingcountsector"

Postby Matilda Faddlesad » Fri Feb 19, 2021 11:53 am

Hi! Im new to map making and i wanted to make a room where, when you kill all the enemies, new stronger ones get teleported in. I tried making a script

script 1 OPEN{
while (thingcountsector (T_NONE, 0, 3000)) {
print (s : "MY PINKY COLLECTION");
}
}


This was just a test to see how it worked before i try the more complex thing i thought of, but it gives me the "identifier has not been declared" error on the "T_NONE"
help please :(
Matilda Faddlesad
 

Re: Problems with "Thingcountsector"

Postby Kappes Buur » Fri Feb 19, 2021 2:27 pm

Works for me™



You may have to either use a more recent version of the editor or just update the ACS definitions.
User avatar
Kappes Buur
 
 
 
Joined: 17 Jul 2003
Location: British Columbia, Canada


Return to Scripting

Who is online

Users browsing this forum: No registered users and 1 guest