Melee Puff not working

Ask about ACS, DECORATE, ZScript, or any other scripting questions here!
Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Melee Puff not working

Postby ibm5155 » Thu Dec 21, 2017 8:22 am

Code: Select allExpand view
ACTOR Axe: Fist 20002
{
  Tag "Axe"
   +WEAPON.MELEEWEAPON
   +WEAPON.NOAUTOAIM
  States
  {
    Ready:
    TNT1 A 1 A_WeaponReady
    Loop
  Deselect:
    TNT1 A 1 A_Lower
    Loop
  Select:
    TNT1 A 1 A_Raise
    Loop
  Fire:
    AXEA A 1
   TNT1 A 0 ACS_NamedExecuteAlways("AXEATTACK",0)
    AXEA B 1 A_CustomPunch(35,1,CPF_NOTURN,"AxePuff",64)
    AXEA CDEFGHIJK 1
    Goto Ready
  }
}

ACTOR AxePuff : BulletPuff
{
   ActiveSound "AXEHWALL"
   AttackSound "AXEMISS_"   
   SeeSound ""
}


The sounds exist and are working when playing it from console, but the puff isn't working :S, what did I mess with it? D:
User avatar
ibm5155
Just Spooky
 
Joined: 20 Jul 2011

Re: Melee Puff not working

Postby Mikk- » Thu Dec 21, 2017 8:26 am

There is already Classes:AxePuff. Maybe try renaming your puff actor
User avatar
Mikk-
yooooooooooo
 
Joined: 30 Jun 2009
Location: Somewhere off Kanagawa
Discord: Mikk0451#3922

Re: Melee Puff not working

Postby ibm5155 » Thu Dec 21, 2017 9:20 am

.... That was indeed correct, ty Mikk- :D
User avatar
ibm5155
Just Spooky
 
Joined: 20 Jul 2011


Return to Scripting

Who is online

Users browsing this forum: No registered users and 2 guests