Page 1 of 1

Cannot compile Realm667 mods into one PWAD

PostPosted: Tue Dec 12, 2017 7:28 pm
by cinnabun_
I am currently working on a mod and I have used assets from the Realm667 site. Whenever I try to compile them into one singular .pk3 in SLADE and load it into GZDoom, I type give all am not able to select them at all. Each one has a unique DoomEdNum and the DECORATE lumps are all completely seperate. They also have their own key configs set, and I do not know the problem. I also noticed that whenever I spawned in the custom monster, it showed up as an error but still attacked and made sounds. Any clue on what could be the issue?

Re: Cannot compile Realm667 mods into one PWAD

PostPosted: Tue Dec 12, 2017 10:58 pm
by Blue Shadow
cinnabun_ wrote:They also have their own key configs set

When KEYCONF lumps are included with weapons, they're typically used to assign slots to weapons. However, they tend to conflict with each other and cause some problems. So, delete those KEYCONF lumps, and edit each weapon and assign it a slot through the use of Weapon.SlotNumber property. More info about weapon slot assignment is here.

I also noticed that whenever I spawned in the custom monster, it showed up as an error but still attacked and made sounds.

It sounds like the sprites of the monster aren't loaded properly. If the sprites are in a WAD, make sure they're between SS_START and SS_END markers. If, however, they are in a PK3, they need to be in a directory which is called sprites.