Decorate Armor in Oblige Wads

Ask about ACS, DECORATE, ZScript, or any other scripting questions here!

Moderator: GZDoom Developers

Forum rules
Before asking on how to use a ZDoom feature, read the ZDoom wiki first. If you still don't understand how to use a feature, then ask here.

Please bear in mind that the people helping you do not automatically know how much you know. You may be asked to upload your project file to look at. Don't be afraid to ask questions about what things mean, but also please be patient with the people trying to help you. (And helpers, please be patient with the person you're trying to help!)

Decorate Armor in Oblige Wads

Postby Abashi76 » Mon Nov 13, 2017 6:12 pm

I successfully added custom weapons to my Oblige wad.

Why won't the red armor work? I did it before but for some reason it is not working.

actor RedArmor : BasicArmorPickup 5210
{
inventory.pickupmessage "Picked up the GigaArmor!"
inventory.icon "ARM3A0"
armor.saveamount 300
armor.savepercent 75
states
{
Spawn:
ARM3 A 6
ARM3 B 7 bright
loop
}
}


I put down the right number for it, just like i did for the custom weapons and ammo. I never had this problem before.

EDIT : Nevermind, i need these weird things that say start and end.
Abashi76
"It doesn't work"
Banned User
 
Joined: 06 Feb 2015

Re: Decorate Armor in Oblige Wads

Postby ramon.dexter » Mon Nov 13, 2017 11:27 pm

Weird things? Markers in wad?
User avatar
ramon.dexter
rudebwoy
 
Joined: 20 Oct 2015
Location: Kozolupy, Bohemia
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: No (Using Stable Public Version)
Graphics Processor: nVidia with Vulkan support


Return to Scripting

Who is online

Users browsing this forum: No registered users and 2 guests