Page 1 of 1

Start Items Not Appearing At Start

PostPosted: Mon Oct 09, 2017 1:37 am
by Aerosplinter
First off, whenever I use the "Give All" command, all of my custom weapons are usable. However, I do not start with the weapons I start with as custom.
Here is my little sneak peak of my weapons sound mod:
MAN'S NOT HOT MOD

DOWNLOAD
You should use a wad editor like SLADE3(The one I used), to check some of the text files.

For the most part, I am trying to figure out how to use my custom weapons at the start, but I only spawn with the Fist as the only weapon to start with. I have spawned with custom weapons before, but I kind of forgot how to spawn with custom weapons due to school. The weapons I currently edited are the pistol and the shotgun. I have some questions :

Did I copy too much of the DECORATE weapons?
Am I using Inheritance incorrectly?
Did I define the actors incorrectly? If so, how do I define them correctly?
Did I make an error in the actors' names for my player class?
Is my player class not added?
Did I add the weapons to the slots incorrectly?
Is there anything that I am missing?

For the most part, how can I spawn with the custom weapons I created other than the fist?


NOTE: I also tried looking up some topics on this forum, but they cannot relate to my problem with the DECORATE weapons I am having trouble with. Usually they want to spawn only with fists, but I want to spawn with my weapons aside from the fist. I also don't want to fill this topic with an ocean of text, but scanning through can be short. So it's only three short text files within this pk3 file.

Re: Start Items Not Appearing At Start

PostPosted: Mon Oct 09, 2017 2:34 am
by Rachael
Moving this to Editing since this is not a system issue.

Re: Start Items Not Appearing At Start

PostPosted: Mon Oct 09, 2017 3:22 am
by Aerosplinter
Rachael wrote:Moving this to Editing since this is not a system issue.


Thank you :wink: , but I still need help... :cry:

Re: Start Items Not Appearing At Start

PostPosted: Tue Oct 10, 2017 5:38 pm
by Matt
Try adding this to your player definition:
Code: Select allExpand view
player.displayname "MANSNOTHOT"
That's the only thing I can think of that's missing from your code. (I didn't bother looking at the Decorate since you said the guns work fine if you use the give cheat)

Re: Start Items Not Appearing At Start

PostPosted: Wed Oct 11, 2017 10:36 pm
by Aerosplinter
Matt wrote:Try adding this to your player definition:
Code: Select allExpand view
player.displayname "MANSNOTHOT"
That's the only thing I can think of that's missing from your code. (I didn't bother looking at the Decorate since you said the guns work fine if you use the give cheat)


But did you spawn with the start items? I only spawn with the fists. Why don't you try testing to see if you can spawn with the items?

Re: Start Items Not Appearing At Start

PostPosted: Thu Oct 12, 2017 10:20 am
by Zhs2
The playerclass works fine. The issue here is that for some reason the actors "HandgunHot" and "ShotHot" do not actually exist, despite being defined in the DECORATE file. Trying to spawn them results in "Unknown actor". Whatever's going on here is pretty baffling, to say the least.

Re: Start Items Not Appearing At Start

PostPosted: Thu Oct 12, 2017 11:29 pm
by Matt
I retyped "ACTOR HandgunHot : " and the handgun works.

It seems to be the space just before the colon. Possibly that non-breaking space was used?
EDIT: Yes it was a non-breaking space. Copypasted the whitespace in quote marks into Google and checked the code on the resulting URL.

This seems like a rather unfortunately inconsistent way of handling nonbreaking spaces. I've posted a bug report though arguably adding some feedback or compatibility is more of a feature suggestion.

Re: Start Items Not Appearing At Start

PostPosted: Fri Oct 13, 2017 12:53 am
by Rachael
This was brought up before as to why ds201's model pack doesn't work, it's the same thing, and it's not something that's likely to change.

You're just going to have to stick with a text editor that does not sneak those in there. :?

Re: Start Items Not Appearing At Start

PostPosted: Fri Oct 13, 2017 1:09 am
by Graf Zahl
What kind of editor did you use? I've never come across one doing this thing.

Re: Start Items Not Appearing At Start

PostPosted: Sat Oct 14, 2017 12:17 am
by Aerosplinter
I used Slade3.