Disable sounds from playing on Doomworld

If it's not ZDoom, it goes here.

Disable sounds from playing on Doomworld

Postby Beed28 » Sat Jun 13, 2015 5:06 pm

Sorry if this feels like a rather silly question. Is there a way to stop sound files from playing when visiting Doomworld, like for example, through a Greasemonkey script or similar? Certain forum pages are set to play sound and that kinda caught me off guard. I only really expect my browser to be making noises when I'm watching videos, like YouTube, or playing Flash games.
User avatar
Beed28
Making entire worlds bounce up and down.
 
Joined: 24 Feb 2013
Location: United Kingdom

Re: Disable sounds from playing on Doomworld

Postby Nevander » Sat Jun 13, 2015 5:51 pm

The only section I know of that does this is Post Hell. I never go there because I spend all my time in WADs & Mods. There's probably a way to block that sound from being played upon load through something like NoScript or something.
Nevander
Self-Banned User
 
Joined: 06 Jan 2014

Re: Disable sounds from playing on Doomworld

Postby Abba Zabba » Sat Jun 13, 2015 5:51 pm

Erm...I don't know about other browsers (I imagine there must be something), but this nifty feature can be enabled in Chrome that lets you mute individual tabs if they're playing audio. It's not an official feature yet as I guess it's still in-dev, but it I haven't noticed any issues.

Type this into your address bar in chrome:

chrome://flags/#enable-tab-audio-muting
User avatar
Abba Zabba
 
Joined: 05 Sep 2011
Location: a place lol!

Re: Disable sounds from playing on Doomworld

Postby Hellser » Sat Jun 13, 2015 5:55 pm

Here's the things you'll want to block using an ad blocker of choice for Post Hell:

http://www.doomworld.com/linguica/fire.gif
http://www.doomworld.com/linguica/scorchsav.swf

Enjoy.

Edit: I'm not for one fond of that damn music and the fire GIF. Having just "Post Hell" is enough; don't need to make it even more immature. It's akin to whoever built that forum thread is on the same level of idiocy of the posts who ended up in Post Hell.
User avatar
Hellser
Remember Citadel
Global Moderator
 
Joined: 25 Jun 2006
Location: Citadel Station
Discord: Hellser#8156
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: Disable sounds from playing on Doomworld

Postby Beed28 » Sat Jun 13, 2015 7:01 pm

Hellser wrote:Here's the things you'll want to block using an ad blocker of choice for Post Hell:

http://www.doomworld.com/linguica/fire.gif
http://www.doomworld.com/linguica/scorchsav.swf


Adblock Plus filter rule wrote:The pattern you entered no longer matches the address to be blocked/whitelisted and will have no effect on it.


Adblock doesn't work. I tried "http://www.doomworld.com/linguica/scorchsav.swf", and then just "http://www.doomworld.com/linguica/" alone.

Also, just to note, a somewhat recent thread complaining about D_RUNNIN actually plays the song when you visit it, which is what caught me off guard. And I'm not sure, but I think the skeleton thread might play sound as well.
User avatar
Beed28
Making entire worlds bounce up and down.
 
Joined: 24 Feb 2013
Location: United Kingdom

Re: Disable sounds from playing on Doomworld

Postby Hellser » Sat Jun 13, 2015 9:01 pm

Try blocking something with your Adblocker of choice (an example, someone's avatar). Go to your Adblock custom list and it should be there. Probably akin to:

Code: Select allExpand view
||http://www.doomworld.com/linguica/fire.gif$domain=doomworld.com


If you ever need to find a specific sound, try loading up your console (F12) and searching for it amongst the HTML code. Bit more of a headache, but once you've built up a list for Doomworld, you don't need to worry about sudden D_RUNNIN attacks.
User avatar
Hellser
Remember Citadel
Global Moderator
 
Joined: 25 Jun 2006
Location: Citadel Station
Discord: Hellser#8156
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: Disable sounds from playing on Doomworld

Postby Athel » Sat Jun 13, 2015 10:04 pm

Huh. When I used to be on DW, there were no sounds for Post Hell at all. Probably because I'm on a mobile device, but still, if tthe sound is as obnoxious as I've heard from others, maybe ever-so-politely ask Linguicia to change it to a less annoying sound? Like a normal fire crackling sound?

Also, D_RUNNIN attacks? Huh?

Edit: OK... Now that's just odd, in all sense of the word.
User avatar
Athel
Oh god what do I do here
 
Joined: 21 Aug 2013
Location: New Jersey
Discord: Athel#2406

Re: Disable sounds from playing on Doomworld

Postby Big C » Sat Jun 13, 2015 11:46 pm

I'm in the D_RUNNIN topic and am having no problems, even with NoScript off. Are you sure you don't have some sort of autoopen script running? (or D_RUNNIN, even? :P )
User avatar
Big C
 
Joined: 19 Oct 2010

Re: Disable sounds from playing on Doomworld

Postby Hellser » Sun Jun 14, 2015 5:40 am

fellowzdoomer wrote:Also, D_RUNNIN attacks? Huh?


Somewhat of a joke. Nothing to worry about. Also, I assumed that the OP was talking about Post Hell. Since I do like to see what sort of stuff goes there. But if more sounds are being played elsewhere .. that would be a problem. Also yeah, the music that's played on Post Hell is a swf file - Shockwave Flash file. AFAIK, no Android (or other mobile device) uses Flash in their browser.
User avatar
Hellser
Remember Citadel
Global Moderator
 
Joined: 25 Jun 2006
Location: Citadel Station
Discord: Hellser#8156
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: ATI/AMD with Vulkan Support

Re: Disable sounds from playing on Doomworld

Postby Beed28 » Sun Jun 14, 2015 5:42 am

Hellser wrote:Try blocking something with your Adblocker of choice (an example, someone's avatar). Go to your Adblock custom list and it should be there. Probably akin to:

Code: Select allExpand view
||http://www.doomworld.com/linguica/fire.gif$domain=doomworld.com


If you ever need to find a specific sound, try loading up your console (F12) and searching for it amongst the HTML code. Bit more of a headache, but once you've built up a list for Doomworld, you don't need to worry about sudden D_RUNNIN attacks.


Doesn't work. If I go into your profile and right-click your avatar, I don't get any Adblock option. Further more, I copied and pasted the code you posted, but I got the same error:
Adblock Plus filter rule wrote:The pattern you entered no longer matches the address to be blocked/whitelisted and will have no effect on it.
User avatar
Beed28
Making entire worlds bounce up and down.
 
Joined: 24 Feb 2013
Location: United Kingdom

Re: Disable sounds from playing on Doomworld

Postby phantombeta » Sun Jun 14, 2015 8:34 am

@Beed28
What browser and what version/fork of Adblock are you using? I tried that in Adblock Plus and it works fine.
User avatar
phantombeta
Tired of being treated like trash by control freaks
 
Joined: 02 May 2013

Re: Disable sounds from playing on Doomworld

Postby Blox » Sun Jun 14, 2015 10:05 am

User avatar
Blox
I am Laziness Incarnate!
 
Joined: 22 Sep 2010
Location: Apathetic Limbo

Re: Disable sounds from playing on Doomworld

Postby Beed28 » Sun Jun 14, 2015 10:46 am

phantombeta wrote:@Beed28
What browser and what version/fork of Adblock are you using? I tried that in Adblock Plus and it works fine.

Mozilla Firefox 38.0.5, and Adblock Plus 2.6.9.1-signed.
User avatar
Beed28
Making entire worlds bounce up and down.
 
Joined: 24 Feb 2013
Location: United Kingdom

Re: Disable sounds from playing on Doomworld

Postby Nevander » Sun Jun 14, 2015 4:40 pm

Beed28 wrote:Mozilla Firefox 38.0.5, and Adblock Plus 2.6.9.1-signed.

I noticed we are both using the same exact versions of browser/addon so I have a question for you. Does YouTube automatically use HTML5 video for you now? I also updated my Flash player the same time I did Firefox a couple days ago and now I notice when I go to YouTube videos, Flash player doesn't activate any more despite being told to always activate in plugins. I check every video, and it's forcing HTML5 video all by itself! Really drove me nuts so I found a small addon that forces Flash player. It works alright, but I have a suspicion that it's not actually fully using Flash. I'd like to go back to the way it was (Flash starting by itself) but that means I'd have to downgrade to Firefox 35 (which is what I was on before when it still worked). You may say what's wrong with HTML5 video? Well for me, only one thing: it can cause BSOD on my computer.
Nevander
Self-Banned User
 
Joined: 06 Jan 2014

Re: Disable sounds from playing on Doomworld

Postby Hellser » Sun Jun 14, 2015 5:35 pm

Might want to get that fixed. YouTube will be fading out Flash in the near future.
User avatar
Hellser
Remember Citadel
Global Moderator
 
Joined: 25 Jun 2006
Location: Citadel Station
Discord: Hellser#8156
Operating System: Windows 10/8.1/8/201x 64-bit
OS Test Version: Yes (Using Development/Testing Version)
Graphics Processor: ATI/AMD with Vulkan Support

Next

Return to Off-Topic

Who is online

Users browsing this forum: No registered users and 0 guests