Zandronum: screenshots not printing properly?

If it's not ZDoom, it goes here.

Zandronum: screenshots not printing properly?

Postby Flynn Taggart » Sat Feb 14, 2015 3:18 pm

I've been having a problem in Zandronum with my screenshots coming out with weird, distorted results and I can't seem to trace the problem. I would ask this on the Zandronum forums but I can't access my account there. to show what I mean, here is a little comparison. I have not had this problem on any of my previous computers.

Here is a normal screenshot taken with the latest GZDoom dev build on my PC, nothing weird and looks perfectly fine:
Spoiler:

Here is how the same screenshot looks taken in Zandronum on my PC, It comes out Black & White with a skewed picture and scanlines(?):
Spoiler:
Flynn Taggart
 
Joined: 11 Feb 2008

Re: Zandronum: screenshots not printing properly?

Postby wildweasel » Sat Feb 14, 2015 3:53 pm

This could be yet another manifestation of the "not a multiple of 4" bug, which I recall happened at unusual resolutions like 1366x768. Try it at any other screen resolution and see if it still puts out that sort of screenshot.
User avatar
wildweasel
change o' pace.
Moderator Team Lead
 
Joined: 15 Jul 2003

Re: Zandronum: screenshots not printing properly?

Postby edward850 » Sat Feb 14, 2015 4:53 pm

It is indeed that. GZDoom fixed this awhile back but zandro is older than the hills, thus the multiple of 4 issue. Using 1360x768 will resolve it.
Also, the picture isn't actually grey scale. Zoom in and you'll notice all the colour is in misaligned columns.
User avatar
edward850
[netcode intensifies]
 
Joined: 19 Jul 2005
Location: New Zealand


Return to Off-Topic

Who is online

Users browsing this forum: No registered users and 1 guest