Opus loop comments not parsed

Post bugs that have to do with sound and/or in-game music here.

Moderator: GZDoom Developers

Forum rules
Please construct and post a simple demo whenever possible for all bug reports. Please provide links to everything.

If you can include a wad demonstrating the problem, please do so. Bug reports that include fully-constructed demos have a much better chance of being investigated in a timely manner than those that don't.

Please make a new topic for every bug. Don't combine multiple bugs into a single topic. Thanks!

Opus loop comments not parsed

Postby Exl » Sat Oct 31, 2020 7:20 am

In the 4.5.0 release Opus is finally supported. The LOOP_START, LOOP_END and LOOP_BIDI tags however are not parsed like they are for FLAC and Vorbis audio.

Here is a pk3 that replaces the MAP01 and MAP02 music. The MAP01 track is a Vorbis file that has an intentionally awful loop start and end specified, and works as expected. The MAP02 music is an Opus track with the same loop comment tags, but it plays without looping. Not until it reaches the end of the track anyway.
User avatar
Exl
 
Joined: 01 Jul 2009

Re: Opus loop comments not parsed

Postby Graf Zahl » Sat Oct 31, 2020 7:26 am

All support for Opus right now is pure playback, it was just a libsndfile replacement.
User avatar
Graf Zahl
Lead GZDoom+Raze Developer
Lead GZDoom+Raze Developer
 
Joined: 19 Jul 2003
Location: Germany

Re: Opus loop comments not parsed

Postby Exl » Sun Nov 01, 2020 5:19 am

I've posted a pull request that adds support for this feature: https://github.com/coelckers/ZMusic/pull/18
User avatar
Exl
 
Joined: 01 Jul 2009


Return to Audio/Music Bugs

Who is online

Users browsing this forum: No registered users and 0 guests